加入收藏 | 设为首页 | 会员中心 | 我要投稿 PHP编程网 - 黄冈站长网 (http://www.0713zz.com/)- 数据应用、建站、人体识别、智能机器人、语音技术!
当前位置: 首页 > 大数据 > 正文

HDU 5832 A water problem 【大数取模,Java 大数也不是万能的。

发布时间:2021-01-24 07:43:12 所属栏目:大数据 来源:网络整理
导读:A water problem Description Two planets named Haha and Xixi in the universe and they were created with the universe beginning. There is 73 days in Xixi a year and 137 days in Haha a year. Now you know the days N after Big Bang,you need t

A water problem

Description

Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang,you need to answer whether it is the first day in a year about the two planets.

Input

There are several test cases(about 5 huge test cases).

For each test,we have a line with an only integer N(0≤N),the length of N is up to 10000000.

Output

For the i-th test case,output Case #i:,then output "YES" or "NO" for the answer.

Sample Input

10001
0
333

Sample Output

Case #1: YES
Case #2: YES
Case #3: NO

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5832

题意

给你一个数,问你这个数是否能够整除137和73

题解:

这两个数互质,其实就是问你能否整除10001(73*137,)

这个直接扫一遍就好了。

用string可能会TLE,所以老老实实用char就好了

Java 都是 MLE,看来Java也不是万能的,

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char a[10000005];
int main()
{
    int kase=0;
    int n;
    //freopen("data/5832.txt","r",stdin);
    while(cin>>a)
    {
        printf("Case #%d: ",++kase);
        int len=strlen(a);
        int mod=0;
        for(int i=0;i<len;i++)
        {
            mod=(mod*10+a[i]-'0')%10001;
        }
        if(mod==0)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}


Java MLE 代码:

import java.math.BigInteger;
import java.util.Scanner;
public class Main {

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner sc = new Scanner(System.in);
        int kase = 0;
        while(sc.hasNext()){
            BigInteger a = sc.nextBigInteger();
            BigInteger mod = BigInteger.valueOf(10001);
            BigInteger ans = a.mod(mod);
            System.out.printf("Case #%d: ",++kase);
            if(ans.equals(BigInteger.ZERO)){
                System.out.println("YES");
            }else{
                System.out.println("NO");
            }
        }
    }
}

(编辑:PHP编程网 - 黄冈站长网)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    热点阅读